Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

For all account questions and concerns, contact Customer Support.

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Scion Spell Issues

AuthorMessage
Explorer
Jun 16, 2010
69
Hi there,

I am currently working on farming some of the new key bosses and while using my max fire wizard, I have been using Fire Scion against Baron Von Bracken in Wysteria.

I noticed that when I use my epic enchant onto my scion it is not changing the damage.

The base damage for the card is 1120, and with the epic enchant being +300 you would think it would be different after the enchant is added, but the card still shows the same damage.

I understand they aren't allowed in pvp but this is a pve instance where im pretty sure its supposed to be working, please let me know if this is something irregular?

Other spells such as FFA, Bull, or Fire Dragon are enchanting properly and adding the +300.

Thanks in Advance!

A+ Student
Mar 31, 2009
1691
They added both a PVP and PVE versions of Scion. Are you using the correct one?

Jk, I don't think it would go into your deck at all would it? No idea.

Explorer
Jun 16, 2010
69
Thanks for the suggestion, but yes, it is the PVE version. I know for certain because I don't ever PVP. And have not even trained those spells on most my characters.

Defender
Oct 16, 2014
194
Just visually or does the spell still deal the same damage?

I remember there was a bug with the Scions and damage enchants in the past, and then later there was a bug with only Fire Scion.

Explorer
Jun 16, 2010
69
Im not sure how to calculate if the spell does the correct damage.

Between critical and damage boost, and depending on mob resist, it would take a lot of testing for me to figure that out. Simply, The spell needs to be fixed one way or another. The enchant will apply itself to the spell and then the damage just stays saying 1120 just like an unenchanted Scion.

I haven't tested to see if this is an issue with all schools. but I did test it in unicorn way with a lost soul. and the Spell does the same thing, applies the enchant but doesn't change the damage cost. Therefore its not a new boss issue its a whole game issue.

I plan on testing and checking on the other scion spells today (8/31) I will keep you posted.

Explorer
Jun 16, 2010
69
Upon testing all school PVE scion and enchants,Primarily tested With Epic Enchant.

Here are my results:

Fire: Doest Not Enchant 1120 ->1120
Balance: Does Not Enchant 955 -> 955
Life: Scion is Heal . . . N/A

Myth: Does Not Enchant 1010 -> 1010

Death : Does Enchant 850 -> 1150
Ice: Does Enchant 930 -> 1230
Storm: Does Enchant 1400 -> 1700

This was determined by using each of my wizards. I now have a max in every school. I wish I knew why about half of the scion spells are showing this correctly and the others are not.

Although the enchant is added to each spell, only some are actually representing a changed value on the card after enchanting. I am not sure if the damage on the hit is being added in the background, but either way it should be shown on the card too after the enchant is added.

I will be submitting a ticket via the help tool, considering none of the forum moderation is looking into this.

Lastly, im kinda surprised to see that the Death scion is weaker than that of the Ice Scion. just a little odd.

Survivor
May 28, 2017
7
I can confirm that I experience this problem as well. Whenever I apply the Epic (or any other damage increasing) enchant on Scion of Fire, the damage value does not change on the card. I took off all my gear and confirmed the amount of damage done with an Epic applied is the exact same as the damage done with no enchant, meaning that it is not just a visual error, the card is really not being enchanted.
Interestingly, if I use an accuracy enchant like Sniper, the accuracy actually does increase on the card. It just seems that damage increasing enchants don't work.

I really hope this is fixed soon