Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Problem buying crowns on website?

AuthorMessage
Survivor
Sep 12, 2009
4
Is anyone else having problems buying crowns on the website? I continue to get an error stating that the card number or security code is incorrect, no matter which card I use. It doesn't seem to be an issue with any of the cards - I checked that out already. I have a family account, and was intending to only buy crowns for one of the accounts...but I've also tried other combinations, putting crowns on this one or that one...and nothing works. Is anybody else running into the same thing??

Explorer
Feb 18, 2009
81
Go to the Help & Support, and contact Kingsisle about that issue. I had a similar issue many months ago, slightly different though - my credit card was being charged just fine for the subscriptions, but when I wanted to buy crowns, I got the message that something or other was wrong with the card. After contacting them, I got an email, and contacted a person there, who helped me out, and I was able to purchase my crowns :)

Survivor
Nov 02, 2009
2
I have that problem when trying to renew subscriptions I end up having to buy gift certificates which ends up costing more as I have a family account

Survivor
Jun 24, 2009
5
I had this happen to me I bought a gift certificate the other day and the charge went threw and i still dont have the crowns.

Administrator
Checking your history, the Gift Certificate was successfully redeemed on December 3rd - Crowns were added and then promptly spent that same day.

You successfully received the Crowns young Wizard.
If you have issues like this, it's best to contact us so we can investigate.

niceonehere wrote:
I had this happen to me I bought a gift certificate the other day and the charge went threw and i still dont have the crowns.


community@wizard101.com
Survivor
May 31, 2009
1
I had the same problem as mamatomady...kept getting that i was putting in wrong CC info,etc. I finally went out and bought a gift card to use instead(probably best in the end anyway)...couldn't get THAT to take...finally I thought..hmm..I'm using Firefox as my current browser..lets try this with IE instead..guess what? It worked!!!Maybe thats the answer/problem/solution?

Survivor
Jun 24, 2009
5
i sent in a support request and they still havent fixed the problem and are telling me everything is fine and that i recived the crowns when i didnt. :(

Administrator
Young Wizard, according to our billing department, you were sent a log of all the Crowns purchases and subsequent transactions that showed you promptly spent those Crowns.

Please refer to the customer support ticket email that you received the log with, and reply to that email if you have further questions.

niceonehere wrote:
i sent in a support request and they still havent fixed the problem and are telling me everything is fine and that i recived the crowns when i didnt. :(


community@wizard101.com
Survivor
Jul 04, 2009
2
You must correct the following errors before you may continue.

* The security code you entered is incorrect. You may have typed it incorrectly. Please re-enter your credit card number and security code.

I am not entering an incorrect security code my code is correct. :( Thank you for everyone who posted a comment :D . I tried the internet explorer that did not work, so my mom is going to buy a gift card.

And to wizard 101 please fix this issue. :x