Welcome to the Wizard101 Message Boards

Player Guide
Game Updates

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Missing in Mooshu - Shiratoki Temple

May 14, 2011
I've been wandering around this dungeon, but I'm missing a few key elements.

1) Wavebringer is missing. I follow the guides, but there's simply nothing in front of the Plague Oni's temple where Wavebringer should be.

2) Tried to light the fires in the Element Temples, but Fire was missing one attacker (there's were 2 in each of the other temples), so I can't light the shrine.

I've tried exiting the dungeon and re-entering (without resetting it)., but no-go.
Next I'll have to retry the dungeon from the start, but I was wondering if anyone else had this problem?

(BTW: I'm Japanese and I don't find Mooshu offensive. So far I've liked all the aress in Wiz101)

May 20, 2010
Wavebringer won't appear until you've done all four Shrines.

I've answered the shrine bug problem probably 40 times. Here's a copy of my other answers:

You MUST activate the Earth Shrine first; otherwise the quest can bug, and you'll have to exit and restart the instance.

The Earth Shrine is the one on the left (northwest) of the four dojos, closest to the river; it's the one you go straight down the path to get to (if you turned left, you'd head to the other three shrines). A Plaguemaster and Water Elemental are inside. After defeating them, you can walk up to the shrine, which is in the back. An interactive menu will appear. If you're at the right shrine, "Earth Shrine" will appear in the menu. If so, activate it and move on. If you still managed to find the wrong (not the Earth) shrine, DO NOT ACTIVATE IT. Leave the dojo and find the correct one. The dojo enemes don't respawn as long as you stay in the dungeon.

If no menu appears at the shrine, and you're at the correct dojo (the one closest to the river), then you've already activated the Air Shrine, and the quest is bugged. To reset the instance, simply exit it. You'll get a warning. Click "OK" to leave, then reenter it. You won't need to wait 90 minutes. If you teleported out, you can reenter the instance, then leave it, then reenter it to reset it.