Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Knights Court, find the evidence

AuthorMessage
Survivor
Jun 07, 2010
3
ok so Im in knights court in marleybone, it tells me to do a quest called "gimme a hand" and Im supposed to FIND EVIDENCE IN KNIGHTS COURT....now I follow my quest arrow and it leads to NOTHING but thin air.

I have scoured the MB forums and found no solution, not even refighting Jaques in the clock tower. I even tried switching realms...but I cannot figure what I am supposed to do. Is this a bug, or a glitch or what, obviously other people have solved this so could someone please tell me what to do, otherwise Im flat out stuck in MB forever......

thankyou in advance

Geographer
Jul 04, 2009
940
Open up your quest log and find that quest. Click on the "?" in the upper left area of the quest and reread just what it is you are suppose to do. If the arrow guide isn't helping you any, call up the Map ("M") and find where you need to go.

Survivor
Jun 07, 2010
3
ok, after scouring the internet for most of the day, I found on Wiki answers, that you go back to AMY BROOKS PLACE AND REKILL THE MONSTERS...
they will drop a glove with the initials JJ...that is your evidence...

now we know...hope that helps anyone that needs to know