Welcome to the Wizard101 Message Boards

Player Guide
Game Updates

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Help! Jacques the Scratcher Glitch.

Jun 27, 2009
I cannot complete the quest with jaques the Scratcher. I have the quest, but it won't tell me where the tower is to find him. I made sure my yellow arrow was on cause it works with every other quest but not this one. I found his tower but then I cannot go inside because the buildings' port won't turn blue. I tried porting to a freind to defeat him. But after I did, it still said that I needed to fight him again. After that I tried the Katz lab but it didn't say I completed the quest. I have no idea what to do now. Please help.
- Sierra LifeGiver, Level 33

Aug 22, 2009
With Jacques the scratcher you get the quest from Linda Milltop. She says something about getting scratched by a brutal cat. The sigils should light up then. If not, check the computer your using. If the computer is slow acessing the internet, try using a more up to date computer. If that isn't the problem, watch how fast or slow your wizard walks or rides. Is it all choppy to where you run, stop, and then get drawn in to a duel? Or is it a regular pace , no stopping in middle of running? Cuase if it's choppy, your computer may have trouble loading everything. If you get logged off unexpected, it's probably your computer. Call someone to check it out. But if the computer isn't the problem, contact KI and explain the problem.

Scarlet Silverspear
Lvl 33 Myth/Fire Wizard :

Aug 22, 2009
Yeah. Sergent Steeg says "talk to Linda Milltop, I think she might have got attacked" so you talk to her which is like 40 paces away and she says "oh, I got attacked by Jaques the Scratcher he ran in to this tower ahhh" so you defeat him.

Dylan AshSpear Level 30 Myth/Life

Dec 23, 2008
This is probably one of those missions where you first have to LOCATE his hideout, and THEN go inside and defeat him. The quest locator arrow doesn't work because your quest is to LOCATE. No hints allowed. This means you have to find your way to the door. (or sometimes you actually have to ENTER the door. Seems to vary.) Only then will the sigils light up.

Porting in does not work because you have bypassed your actual quest.

Now, as to why it's not triggering quest completion when you show up at the door, I don't know. If Linda sent you there, it should work. It's possible (since you can't use the quest locator) that you're not really at the right door. If I remember correctly, Jacques shows up in various places.