Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Trophey Quest Help

AuthorMessage
Survivor
Aug 24, 2008
13
In the mission where you are helping out the mander get his father's gear from the vault. I can not figure out the part of the clue that says patience is a virtue. I have tried sitting and doing nothing for over an hour. I tried randomly clicking the obelisks in the room and tried to come up with a pattern. I did notice a moon and sun slab of stone in the room every time I come in. I tried clicking both moon and sun obelisk and just waiting. Does anyone know the solution to this puzzle?

Survivor
Aug 24, 2008
13
I guess my brain was not working. After a break where I did finish the Crocosphinx, I cam back to this quest and was able to complete it. Funny how taking a nap and not thinking of something clears things up.

Survivor
Aug 31, 2008
2
Try activating the moon obelisk on the side where moon slab of stone is and the sun obelisk on the side where the sun slab of stone is. And then activate one of the crocodile (or whatever the othe one is lol) obelisk. That worked for me. Good luck!

Survivor
Jul 31, 2008
4
Hi there
Go and stand by the door you came in and look on other side for the third symbol.It was an alligator for me,not sure if it's the same for everyone.
Then once you activate all 3 symbols the chest will appear.
Good luck

Survivor
Sep 03, 2008
42
Survivor
Sep 02, 2008
3
Ako gives this quest after defeating the last guy in the Arena. You have to talk to him first, then talk to the Arena guy, then back to him. You'd get an item and this quest.

BTW, the moon, sun and alligator obelisk worked for me. ^_^

Explorer
Jun 21, 2008
61
"Patience is a virtue that all do not have."
--Plumblossum

Let me go step by step here.

You first enter the room, you may or may not see a silver chest. No matter what you do with the chest, you can't get it or open it.

Go out room and stop as soon as you go in. Well, you don't have to go out of the room, just go where you can see the whole play area.
Ahh, what is that but a code.
Activate code in order you see.

Wow, there's a third piece to the code.
Without deactivating the two obelisks you activated, activate the last
and third obelisks.

Now go to the silver chest and press x.