Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Serious lag spikes / fps drops

AuthorMessage
Survivor
Jun 15, 2012
4
Okay, so my Wizard 101 was working perfectly on the 7th. I bought membership on the 7th with a Wizard 101 card. I played for a bit and went to areas I need to unlock. But, the next morning I was experiencing serious lag. Once I got i n Wizard 101 my fps dropped to about 5-20 fps (I'm assuming). So every time I move I get serious lag. I tried looking at other forums for answers but none helped me. I've turned bloom active off, shadows of, smoothing off, fullscreen off, quest helper off, graphics to low, and decreased my resolution, I still feel the same lag. The loading screen when I go from place to place takes over a minute. (I timed it). My computer has 12 GB of RAM. It lags the same way on my other wizards. I even sold alot in my inventory. Nothings working, please help!

Administrator
Hello,

If you send an email to support@wizard101.com, they may be able to help you with this issue.


community@wizard101.com
Survivor
Jul 26, 2014
4
Wow! Me too. On Thursday it was all fine, however on Friday I tried logging back in and even at wizard101 loading screen (upon pressing play) was lagging horribly. I tried everything, Internet speed check, restarting my computer a few times and even re-installing the game. It only really started to occur on the Friday out of a sudden. I emailed support and am waiting for an answer.

So I guess you are not alone!!

Survivor
Jun 15, 2012
4
Yes I am glad to hear I'm not alone. I've been emailing support and they're trying their best to help me fix it

Survivor
Jul 26, 2014
4
So is your game laging horribly? Like, every turn you make it freezes or does not respond. Especially when switching realms/worlds/homes. Because that is what I am experiencing, I found out all my gardening is dead. But it'd take a good 30 minutes or more with that lag to revive all the seeds. So can you keep the post updated of what they say? Because I got this pattern of reply every 2 days. I understand perfectly that they are busy, but you'd be a source of knowledge in between.
So far they are saying I am losing packets/signals on one of the servers/routes of receiving the file(s). Still waiting on a reply, but I am phoning my Internet Provider soon to see if it is their problem. So far the results aren't very positive.

Survivor
May 05, 2010
29
I got similar but not as bad as described.

Survivor
Jun 15, 2012
4
They were unable to help me, but they said that it was latency, and that I needed to contact my ISP. I don't think this problem is going to be resolved anytime soon.

Survivor
Jul 26, 2014
4
So, then you have the exactly the same issue as me. That's what they said to me, too. I have been researching, and to get to the wizard101 server, my signal for some reason travels through a complete unrelated and uneccessary country (not mentioning names as I thinks I am not allowed to). I have contacted this company and waiting a reply. I think your signal is travelling the same as mine.
Now for the interesting part; I can play pirate101 without lag! I trace routed that signal and it's going straight to US compared to Wizard101 signal. But the sad part is that there is nothing much that we can do.