Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

We are aware of the recent Heartbleed Bug internet vulnerability issue and can confirm that none of the KingsIsle systems or websites were impacted. If you wish to have further clarification about the bug itself visit http://heartbleed.com.

"Retribution" Quest not working?

AuthorMessage
Survivor
Jul 16, 2011
3
"Retribution" Quest not working?
I was trying to do the quest "Retribution" on Krokoptopia at about 5:30 EST 7/25/11 on Unicorn server. I did all the steps until I got to the end. The last one was to defeat Krokenhotep. I lit up the obelisks and waited quite awhile, but the door to his lair didn't open. I turned them all off and lit them again, waited again, the door still didn't open. I looked around for other clues or instruction. I then spent about a half hour trying different ways of turning on the obelisks in different orders, no luck. I then went out and asked at the Oasis, one person said to just wait longer. I went back, tried again, the door still remained shut.

Is thie Retribution quest bugging or was I doing something incorrectly? If it was me, I apoligize, but I tried to figure out any possible angle before asking here.

Edit: found suggestions for opening it elsewhere in the forum! But I did check back in the dialog record in the quest notebook, and Salek the Wise isn't listed as giving the clue. So if a player misses him giving it and opens the dialog record to try to figure out the obelisks, the player won't find anything.

Thanks.