Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Pierce -- It just doesn't add up

AuthorMessage
Delver
Jun 29, 2011
212
My gear gives me 10% armor piercing, but when I hit a 50% tower shield it blocks 41% of the damage. I know this is only marginal, but in some cases that 1% could mean the difference between winning or losing a duel. Please fix this with the next update.

Thank you.

Archon
Sep 17, 2012
4117
Is it purely gear boost? What school and gear? I only ask because all my pierce boosts work correctly on my wizards. My only thought was if there was a fractional boost from a pet talent it my be like resist where a 10 might say 10% but it's really 9% because it's stats based.

Delver
Jun 29, 2011
212
seethe42 on May 6, 2014 wrote:
Is it purely gear boost? What school and gear? I only ask because all my pierce boosts work correctly on my wizards. My only thought was if there was a fractional boost from a pet talent it my be like resist where a 10 might say 10% but it's really 9% because it's stats based.
The 10% pierce is from my Myth Hades gear (Hades' Helm of Dread, Armor of Unknown Tartarus, Boots of Unknown Tartarus), so it could not be fractional.

Archon
Sep 17, 2012
4117
I don't have the Helm of Dread so I would bet that's where the bug is. Saying 5 but only giving 4. My Unknown Tartarus gear all gives the correct pierce. Try wearing only the helmet and see if it gives the correct amount or not.

Delver
Jun 29, 2011
212
seethe42 on May 8, 2014 wrote:
I don't have the Helm of Dread so I would bet that's where the bug is. Saying 5 but only giving 4. My Unknown Tartarus gear all gives the correct pierce. Try wearing only the helmet and see if it gives the correct amount or not.
I've tested other gear and had the same problem, so it's not gear specific.

Hero
Dec 16, 2009
772
I am having the same issue, my gear is giving me 15% pierce on display but is only piercing 14% in effect.

Armiger
Mar 18, 2009
2381
Same issue was noted in 2011 regarding the combination of all resistance stats being added up incorrectly.

https://www.wizard101.com/forum/halstons-laboratory/ki-please-fix-your-math-when-adding-43754