Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Lag and freeze every 2-3 seconds

AuthorMessage
Survivor
Mar 16, 2012
4
Hello,
My computer usually runs decently fast. However, over the past few weeks (since the Ultra Test Realm is on), I have noticed that, while playing Wizard101, it lags quite badly. Indeed, every 2-3 seconds, the game suddenly freezes for about half a second and it lags. Changing realm, lowering the graphics, disabling the shadows, etc. do not work. It still lag and freeze. I'm confused with this because I have played this awesome for about 3 years (since 2012) and I never had any lag issue. As I said, it started recently along with the Test Realm.

Sunday, as you guys know, the Lost Page event was on. While I was doing it, the lag and freezes weren't there, the game ran perfectly fine. However, as soon as I did all the event's quests and got all the event's badges, the lag and freezes came back.
Also, when I play on my low-level wizard (Storm wizard level 24), the game does not lag at all. It runs perfectly fine. However, when I play on my high-level wizard (Death wizard level 100), the game, like I previously said, lag and freezes every 2-3 seconds.
Any solutions?
Thank you for reading this and I hope you have a wonderful day (or night)!

Sorry for my bad English, by the way. It's not my first language.

Archon
Feb 07, 2011
3174
Kigiri1 on Jul 10, 2015 wrote:
Hello,
My computer usually runs decently fast. However, over the past few weeks (since the Ultra Test Realm is on), I have noticed that, while playing Wizard101, it lags quite badly. Indeed, every 2-3 seconds, the game suddenly freezes for about half a second and it lags. Changing realm, lowering the graphics, disabling the shadows, etc. do not work. It still lag and freeze. I'm confused with this because I have played this awesome for about 3 years (since 2012) and I never had any lag issue. As I said, it started recently along with the Test Realm.

Sunday, as you guys know, the Lost Page event was on. While I was doing it, the lag and freezes weren't there, the game ran perfectly fine. However, as soon as I did all the event's quests and got all the event's badges, the lag and freezes came back.
Also, when I play on my low-level wizard (Storm wizard level 24), the game does not lag at all. It runs perfectly fine. However, when I play on my high-level wizard (Death wizard level 100), the game, like I previously said, lag and freezes every 2-3 seconds.
Any solutions?
Thank you for reading this and I hope you have a wonderful day (or night)!

Sorry for my bad English, by the way. It's not my first language.
i had the same problem on my level 100 storm wizard~ this was a known glitch that broke the game for anyone who had finished it, but i didn't know it was still a thing (since i am no longer affected).

yes, i remember it well... none of my other wizards were affected, and even combat was fine for my poor storm. it was trying to move around that made my screen freeze every 2-3 seconds and basically made the game unplayable.

prior to that, i had played virtually trouble-free for 4 years, and my laptops (while not super high-end) both exceed the system requirements. so i contacted kingsisle support, and they told me to turn off my quest arrow; it fixed the issue instantly, though i can now turn it back on without issue.

here's how: press ESC on your keyboard and click the third panel under options, then choose 'off' beside the quest helper function.

if this doesn't work, i recommend contacting ki support for further help.

-von

Survivor
May 05, 2010
29
I thought it was only me! it usually happens to me when i'm switching screens in the menu.

Survivor
Mar 16, 2012
4
Dr Von on Jul 12, 2015 wrote:
i had the same problem on my level 100 storm wizard~ this was a known glitch that broke the game for anyone who had finished it, but i didn't know it was still a thing (since i am no longer affected).

yes, i remember it well... none of my other wizards were affected, and even combat was fine for my poor storm. it was trying to move around that made my screen freeze every 2-3 seconds and basically made the game unplayable.

prior to that, i had played virtually trouble-free for 4 years, and my laptops (while not super high-end) both exceed the system requirements. so i contacted kingsisle support, and they told me to turn off my quest arrow; it fixed the issue instantly, though i can now turn it back on without issue.

here's how: press ESC on your keyboard and click the third panel under options, then choose 'off' beside the quest helper function.

if this doesn't work, i recommend contacting ki support for further help.

-von
Dr Von,
Thank you for this solution, but I have done every single side quests and main quests. So, this way, I have no questing arrow (because I have no quests to do) and it still lags/freezes.
However, I have disabled the Quest Finder and the game works perfectly fine now.