Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Is there a way to change key commands?

AuthorMessage
Survivor
May 06, 2010
11
My arrow keys are so close to my End key that sometimes I port out of dungeons by mistake. This is a MAJOR problem in Dragon Spyre when I'm questing with someone inside a dungeon. I port out with the End key by accident and I got no way back. I was half way through, too. Any help would be appreciated.

Explorer
Apr 29, 2010
60
There is a way:

Gamma wrote:
Currently the Page Down and Page Up keys are bound (in Wizard101) to Set Marker and Recall to Marker respectively.

You can edit a text file to change these settings but it takes a little work, if you’re willing.

Locate the config.xml file in the following folder:
C:\Program Files\KingsIsle Entertainment\Wizard101\Bin
(this may vary slightly with Vista)

Save a copy of the file before you do anything!

Right click on the config.xml file and Open With…Notepad.

Almost at the bottom, you will find the following entries. I know it looks a little overwhelming but it’s ok, we have a backup copy ?

Find these and delete the completely, meaning select everything between the first <RECORD> and the last </RECORD>

<RECORD>
<Alt TYPE="BYT">0</Alt>
<Ctrl TYPE="BYT">0</Ctrl>
<Event TYPE="STR">MarkLocation</Event>
<InputType TYPE="STR">keyboard</InputType>
<Key TYPE="STR">pagedown</Key>
<KeyState TYPE="STR">up</KeyState>
<Shift TYPE="BYT">0</Shift>
</RECORD>


<RECORD>
<Alt TYPE="BYT">0</Alt>
<Ctrl TYPE="BYT">0</Ctrl>
<Event TYPE="STR">RecallLocation</Event>
<InputType TYPE="STR">keyboard</InputType>
<Key TYPE="STR">pageup</Key>
<KeyState TYPE="STR">up</KeyState>
<Shift TYPE="BYT">0</Shift>
</RECORD>


Save the file, and restart Wizard101. Try pressing PAGE DOWN and if you do NOT create a marker in that location, then you were successful.

If something doesn’t quite work, let me know, and I’ll do my best to work with you to disable these keys.

Survivor
May 06, 2010
11
Should this part for changing it look like this then?

<RECORD>
<Alt TYPE="BYT">0</Alt>
<Ctrl TYPE="BYT">0</Ctrl>
<Event TYPE="STR">Commons</Event>
<InputType TYPE="STR">keyboard</InputType>
<Key TYPE="STR">end</Key>
<KeyState TYPE="STR">spacebar</KeyState>
<Shift TYPE="BYT">0</Shift>
</RECORD>

Because I want to switch Commons with jump. :)

This isn't officially supported but I think what you want is:

<RECORD>
<Alt TYPE="BYT">0</Alt>
<Ctrl TYPE="BYT">0</Ctrl>
<Event TYPE="STR">GoHub</Event>
<InputType TYPE="STR">keyboard</InputType>
<Key TYPE="STR">Space</Key>
<KeyState TYPE="STR">down</KeyState>
<Shift TYPE="BYT">0</Shift>
</RECORD>

<RECORD>
<Alt TYPE="BYT">0</Alt>
<Ctrl TYPE="BYT">0</Ctrl>
<Event TYPE="STR">EmoteJump</Event>
<InputType TYPE="STR">keyboard</InputType>
<Key TYPE="STR">end</Key>
<KeyState TYPE="STR">up</KeyState>
<Shift TYPE="BYT">0</Shift>
</RECORD>

The first section puts "go to commons" on the space bar. The second section make the end key "jump".

Arthur

Survivor
May 06, 2010
11
I found the folder but I can't find a file called Bin. If it helps I'm running Vista.

Survivor
Jan 23, 2010
1
TheApostle wrote:
I found the folder but I can't find a file called Bin. If it helps I'm running Vista.


In Windows 7 the config.xml file is located at
C:\ProgramData\KingsIsle Entertainment\Wizard101\Bin

I would guess that the location is the same for Vista.

Note: the ProgramData directory is hidden by default so you might have to adjust
Tools->Folder Options->View->Show hidden files, folders, and drives