Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

We are aware of the recent Heartbleed Bug internet vulnerability issue and can confirm that none of the KingsIsle systems or websites were impacted. If you wish to have further clarification about the bug itself visit http://heartbleed.com.

Invalid 3D device type

AuthorMessage
Survivor
Jul 20, 2011
1
Invalid 3D device type
I've been working on this for a very long time. Wizard101 used to work for my Dell desktop computer. It's set up for windows 7 I believe and it was different settings than the steps on a different forum. I get the same error message that says Initialization error: Direct3D renderer creation error: Creation failed: Invalid 3D device type. Then is closes out of the white screen that is supposed to be loading wizard101. This is very annoying and I sent a message to the contact us icon almost a week ago and I haven't gotten a response, but I'd very much like to play wizard101 on this desktop like I used to. I've kept this to myself for almost a year trying to fix it by myself but sadly it has not worked at all! It's about time that this problem is resolved! I'd like to know how to fix it sometime today if possible. I've tried my very best to work with this patiently but I'm just losing my patience. A year is too long to deal with this! I've been trying to figure out what it'd be on this version for the directions but I haven't been able to figure it out. Please help me with this annoying issue, Thank you.

Survivor
Sep 15, 2010
2
Re: Invalid 3D device type
When i was trying to play w101 on my laptop it happened the same to me, it was very annoying, I agree. What i did is to download w101 again, when i saw that it didnt worked, i went to google and searched that direct3d thing. Unfortunately, it has nothing to do with w101... After a week, i deleted w101 again, after nearly a month i downloaded it once again and it was all fine.

Explorer
Jul 17, 2009
62
Re: Invalid 3D device type
I just had this same problem less than a week ago. I googled this and it directed me to a post here on the forums. This is what I found...................
1) Open the display properties in the control panel.
2) Click settings tab, click advanced and then click the Troubleshooting tab.
3) Drage the Hardware Acceleration slider to the right(full).
4) Click Apply, OK and then click OK again.
5) Restart your PC.
Hope that resolves the issue for you. It did for me and everything works perfectly now.