Welcome to the Wizard101 Message Boards

Player Guide
Game Updates

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

For all account questions and concerns, contact Customer Support.

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Crafting recipe isn't showing in crafting table???

May 02, 2012
hi! So I'm working on my wizard's crafting because I know you can craft good gear and awesome houses. I'm working on the mooshu quest right now. I bought the seal of the seraphim recipe and went to my basic crafting table, and the recipe doesn't show up! I tried logging out of my wizard than going back on her, I tried turning the game of free completely, nothing's working! This is really aggravating...

Jordan Darksword
lvl 61
Legendary necromancer

A+ Student
Dec 24, 2009
Once you hit Mooshu and beyond, you have to buy an Equipment Crafting Table in order to craft gear items. Go into any world's furniture shop and you'll find three different crafting tables. Buy the Equipment one for now, but keep in mind you'll soon be needing the other two as well.

The card crafting table is used for both treasure cards, and transmuting more common reagents into rare ones. (Example, gather enough black lotus and you can change 15 black lotus into 1 black pearl.)

The furniture crafting table will be needed for the final Dragonspyre crafting quest.

I think they all cost about $2500 gold.

Good luck!

Alia Misthaven