Welcome to the Wizard101 Message Boards

Player Guide
Game Updates

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Belloq(Three Points) Can't finish quest.

May 10, 2009
Edward ThunderBlade Level 85 Diviner
Yesterday I was at the front lines(Azteca) soloing a dungeon when I found myself in the Boss room. I had already run out of health due to the rest of the dungeon(and being storm), and had been left with 800-900 health and no potions before the boss room. There was an NPC Belloq along with an enemy but i ignored it. I managed to kill the minion before dieing by the hands of Belloq in battle. When i had returned to the dungeon everybody was killed except Belloq, so I fought and killed him. After I won I ran around to the back, following the arrow without successfully completing the quest "Explore Black Sun Chamber in Three Points".. UNTIL i was suddenly pulled into a battle with no enemy. I could open my backpack, deck, etc.. but i could not leave and there was no enemy in the battle. Trying to free myself i relogged in and ran through the dungeon again just to be sucked into an enemyless battle once i reached the boss chamber. I ran through many times in vain.

I had only tried this dungeon once so it might not be a reoccuring problem.
TLDR; Extra NPC Belloq, Can't finish quest ^ due to being sucked into "enemyless" battle after defeating boss.
This is mostly for game repair, but if it happens to me again
Does anybody have a solution?