Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Norton's Tower bugged?

AuthorMessage
Survivor
Sep 05, 2013
10
I am currently doing the quest "To Sunken City", and have completed it to the sub-quest "Under Lock and Key". I have defeated the first two floors of Norton's Tower, but the gate won't open to allow access to the third floor. My quest book says the next goal is to defeat Norton, my compass arrow is pointing to the closed gate, yet I can't continue. I have tried teleporting to the Commons then back, and even completely closed the client then re-entered, with no success. Is this a known bug or a freak occurrence? Also, any ideas on what else I might try? I am trying to stay logged on so that I won't lose my progress and have to repeat this dungeon from scratch.

Edit: I finally gave up and completely reset the instance. The second time through it worked perfectly and I was able to complete the quest. I still have no idea, though, what caused this issue or if there is anything else I could have tried to fix it before starting over from the beginning.

Survivor
Sep 11, 2012
49
I contacted support about this. Apparently, you have to defeat both of the enemies on the second floor in the same battle or the door won't open. It's not a bug.