Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Missing My Turn?

AuthorMessage
Defender
Jan 08, 2010
104
I have encountered this bug a few times now, and it is starting to hinder my pvp and pve capabilities. In a pve fight I clicked the spell spirit blades, clicked myself (there was nobody else with me, and it was in a sigil area, but not a dungeon) and then nothing happened. As the timer slowly ran out, I frantically clicked back and forth several times with the same spell and different ones and I was still forced to pass. The next round, though, I could select my spell again and it worked this time. I checked my connection as well and my connection was all green, so It was not that so I don't know what could be causing this, but it needs to be fixed asap. Let me know if you have a solution or encountered the same or similar problem.

Brian FariyFist level 82

Explorer
Apr 10, 2013
68
I have never encountered this or heard about it but if it is worth the time maybe you could try uninstalling then reinstalling the game. Again I have never heard about this so this is just a guess. Tell me if it works!
Justin GoldenStone

Delver
Apr 08, 2015
250
Ambrose122 on May 29, 2015 wrote:
I have encountered this bug a few times now, and it is starting to hinder my pvp and pve capabilities. In a pve fight I clicked the spell spirit blades, clicked myself (there was nobody else with me, and it was in a sigil area, but not a dungeon) and then nothing happened. As the timer slowly ran out, I frantically clicked back and forth several times with the same spell and different ones and I was still forced to pass. The next round, though, I could select my spell again and it worked this time. I checked my connection as well and my connection was all green, so It was not that so I don't know what could be causing this, but it needs to be fixed asap. Let me know if you have a solution or encountered the same or similar problem.

Brian FariyFist level 82
Yes, I have encountered this bug too I think. All I do is keep clicking the spell again until it works. Repeatedly. And it's not just with blades, it happens with any spell. Just try to click the spell again, and you'll be fine.

Survivor
Apr 18, 2015
2
Omg read only i have been having the same problem, but sometime i just dont see any cards at all or any chat or movement or casting spell or anything until i died, and thats when everything is back to normal. It's been giving me so much loses... N sometime i get stuck on loading screen too n give me loses... -.-