Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Invisible Wizard

AuthorMessage
Defender
Jun 17, 2012
156
I noticed since the sizzling summer update has come to the live realm that frequently when I port home or to the common area of any world, my mount appears and my wizard is invisible. I am still there on my mount, but I cannot be seen, (at least by me). This is probably some sort of bug but I think it is hysterical and personally love cruising around on my mount as the "Invis-a-wiz". Usually my wizard will appear when I dismount or enter a building, etc.

Has anyone else experienced this since the beginning of August? I am not complaining or asking this to be fixed, it is comical.

Autumn WH (sometimes invisible lol)

Illuminator
Aug 03, 2016
1445
This has happened to my wizards sporadically also.

It's kind of funny

Geographer
Mar 16, 2012
858
Nordic Champion on Aug 26, 2019 wrote:
I noticed since the sizzling summer update has come to the live realm that frequently when I port home or to the common area of any world, my mount appears and my wizard is invisible. I am still there on my mount, but I cannot be seen, (at least by me). This is probably some sort of bug but I think it is hysterical and personally love cruising around on my mount as the "Invis-a-wiz". Usually my wizard will appear when I dismount or enter a building, etc.

Has anyone else experienced this since the beginning of August? I am not complaining or asking this to be fixed, it is comical.

Autumn WH (sometimes invisible lol)
Yes, in fact, I also made a bug report & want it fixed; even though it's only cosmetic, I like seeing my wizard. What mount were you using?

Defender
Jun 17, 2012
156
anecorbie on Aug 26, 2019 wrote:
Yes, in fact, I also made a bug report & want it fixed; even though it's only cosmetic, I like seeing my wizard. What mount were you using?
Hi Anecorbie! I saw your thread just after my post. I guess we were both thinking about this! I was using a 15 day sabertooth rental mount, permanent panda mount, balance brume, life brume, white stag perm mount and ice skates perm mount to name a few. It has happened on all of my wizards also. Weird huh?

Sparkle Tude, I agree it is funny!

Autumn WH

Survivor
Aug 24, 2013
10
Happens to me, too! I agree its quite funny. I have a shark skirunner mount and looks like I morphed into the mount without a wizard on it.

Astrologist
Feb 28, 2014
1037
Awsome! I'd love to go invisible. It's like that cloak Harry Potter wore. This will give me an element of surprise on all enimies.

Survivor
Jan 20, 2011
4
I had this happening too and some of my friends have complained about it happening. I was on roller blades and it's happened to my seraph wings too. I agree though, it's quite funny.

Rowan FirePetal

Geographer
Mar 16, 2012
858
Since this is happening to more wizards, then Sparck's suggestion in my bug report that it might be a graphics card error, needs to be looked at more carefully now.
Surely, not everyone experiencing this has a poor graphics card?

Illuminator
Aug 03, 2016
1445
"Surely, not everyone experiencing this has a poor graphics card?"

Not that I know of.

It's happened on more than one mount, btw, all perm.