Welcome to the Wizard101 Message Boards


Player Guide
Fansites
News
Game Updates
Help

Follow important game updates on Twitter @Wizard101 and @KI_Alerts, and Facebook!

For all account questions and concerns, contact Customer Support.

By posting on the Wizard101 Message Boards you agree to the Code of Conduct.

Blades or Shields not casting as expected

AuthorMessage
Survivor
Apr 03, 2009
25
Good Day,
Every now and then I will cast a Blade (Death Blade or Balance Blade from gear) or a Tower Shield and click on my actual character in the battle circle on screen to cast it. On my screen where it displays what your friends have cast for that battle round, it reflects that I cast my Blade or shield, but when it is my turn in the battle sequence, it does not cast resulting in a wasted round since I now have no Blade or shield applied to my character.

Other players that I am fighting with will tell me that the spell did not show on their screen that I cast any spell at all. I have noticed that when casting those particular spells, that if I click on my name banner that displays total pips, etc.. the spells will cast as expected.

Please advise on if this is a known bug and if there is a fix coming OR is this just me reporting it for the first time. Thanks!

Christo Deathgiver
Legendary Necromancer
Founder of Mercenaries for Hire

Adherent
Mar 18, 2009
2738
This has happened to me on rare occasion too. The system does not recognize that I choose a spell and times out. On my screen everything looks normal, but to everyone else it looks as if I didn't choose a spell and let the timer run out. Sometimes if I cancel and re-select the card, it will work, but I noticed this glitch over the last three weeks or so. I don't remember this issue before that time.

It is probably an issue with communication between my computer and the server (internet based), however, I only noticed it recently.

Delver
Mar 13, 2011
278
This has happened to me twice. First was long ago and can't remember which spell.

The second time was today. It did exactly what you describe when I tried to triage myself.